Windows reboots instead of Shutdown|Sleep|Hibernate

Try the following if your computers reboots instead of shutting down | sleep | Hibernate.

Clear the CMOS - Remove battery for 5 minutes or use a jumper to clear the CMOS.
go into BIOS and load optimized / fail-safe defaults.

Setting fast mode and all the other suggestions do not work because they have nothing to do with causing the system to reboot.